I can't use the Miracast application

TV BOX

I can't use the Miracast application

The Mircast application only works with a smartphone or tablet with Android 4.2 and above, compatible with Miracast.